Уважаемый посетитель сайта! На нашем сайте вы можете скачать без регистрации книги, тесты, курсовые работы, рефераты, дипломы бесплатно!

Авторизация на сайте

Забыли пароль?
Регистрация нового пользователя

Наименование предмета

Яндекс.Метрика
Введение………………………………………………………………3
Теоретическая часть………………………………………………….4
Заключение…………………………………………………………..12
Практическая часть………………………………………………….13
Общая характеристика задачи……………………………………...13
Список использованной литературы………………………………21


Введение.

Криптографическое преобразование – один из наиболее эффективных методов, значительно повышающих безопасность:
• передачи данных в компьютерных сетях;
• данных, хранящихся в удаленных устройствах памяти;
• информации при обмене между удаленными объектами.
Защита информации методом криптографического преобразования заключается в приведении ее к неявному виду путем преобразования составных частей информации (букв, цифр, слогов, слов) с помощью специальных алгоритмов либо аппаратных средств и кодов ключей.
Большинство современных алгоритмов шифрования образуются на основе комбинирования базовых видов шифров: перестановки, замены (подстановки).
В теоретической части раскрыты основные понятия криптографического преобразования (криптография, шифр, шифрование, расшифровка, ключ, стоикость); методы защитных преобразований; даны понятия симметричных и несимметричных(асимметричных) криптосистем.
В практической части произведен расчет суммы скидки продукции с использованием ППП. Построена гистограмма динамики стоимости продукции под влиянием скидки. Работа проводилась в excel, с использованием функций ПРОСМОТР, ОКРУГЛ и ОСТАТ, а также мастера диаграмм.


Криптографические методы защиты информации и их использование при работе в сети.
Криптографическое преобразование – один из наиболее эффективных методов, резко повышающих безопасность:
• передачи данных в компьютерных сетях;
• данных, хранящихся в удаленных устройствах памяти;
• информации при обмене между удаленными объектами.
Защита информации методом криптографического преобразования заключается в приведении ее к неявному виду путем преобразования составных частей информации (букв, цифр, слогов, слов) с помощью специальных алгоритмов либо аппаратных средств и кодов ключей.
Криптография известна с древнейших времен, однако она всегда оставалась привилегией правительственных и военных учреждений. Изменение ситуации связывается с публикацией в 1949 г. книги К. Шеннона по теории информации и кибернетике, когда к криптографическим методам преобразования информации обратились многие ученые, банковские и коммерческие системы.(1, с.539)
Криптография – наука о методах обеспечения секретности и/или подлинности (аутентичности) данных при их передаче по линиям связи или хранении. Исследования в области криптографии развиваются по двум направлениям: шифрование данных и создание алгоритмов электронной цифровой подписи. Шифрование имеет целью скрыть содержание (обеспечить конфиденциальность) хранимой или передаваемой по сетям информации, электронная подпись имеет целью гарантировать достоверность и целостность передаваемых по глобальным сетям сообщений.
Шифр – это множество обратимых преобразований формы сообщения, проводимых с целью его защиты.
Процесс применения обратимого преобразования шифра к открытому тексту называется шифрованием, а результат этого преобразования шифртекстом или криптограммой. Соответственно, процесс обратного преобразования шифртекста в открытый текст называется расшифрованием.
Ключ – потенциально изменяемая совокупность секретных данных, определяющих конкретное преобразование из множества возможных преобразований шифра.
Важным понятием криптографии является стойкость, под которой понимают способность противостоять попыткам криптоаналитика дешифровать перехваченное сообщение, раскрыть ключи шифра или нарушить целостность и/или подлинность информации.(2, с. 341)
Для преобразования (шифрования) используется некоторый алгоритм или устройство, реализующее заданный алгоритм, которые могут быть известны широкому кругу лиц. Само же управление процессом шифрования осуществляется с помощью периодически меняющегося кода ключа, обеспечивающего каждый раз оригинальное представление информации при использовании одного и того же алгоритма или устройства. Знание ключа позволяет относительно быстро, просто и надежно расшифровать текст. Однако без знания ключа эта процедура может оказаться практически невыполнимой даже при использовании компьютера.
К методам криптографического преобразования применимы следующие требования:
• метод должен быть достаточно устойчивым к попыткам раскрытия исходного текста на основе зашифрованного;
• обмен ключа не должен быть труден для запоминания;
• затраты на защитные преобразования должны быть приемлемы при заданном уровне сохранности информации;
• длина зашифрованного текста не должна превышать длину исходного текста.

Существует несколько методов защитных преобразований, которые можно подразделить на четыре основные группы: перестановки, замены (подстановки), аддитивные и комбинированные методы.
Для методов перестановки и замены (подстановки) характерна короткая длина ключа, а надежность защиты определяется сложностью алгоритмов преобразования, и, наоборот, для аддитивных методов характерны простые алгоритмы и длинные ключи.
Основными методами криптографического преобразования считаются методы перестановки и замены. Суть первого метода заключается в разбиении исходного текста на блоки, а затем в записи этих блоков и чтении шифрованного текста по разным путям геометрической фигуры.
Шифрование методом замены заключается в том, что символы исходного текста (блока), записанные в одном алфавите, заменяются символами другого алфавита в соответствии с принятым ключом преобразования.(1, с. 540)
Существующие криптосистемы подразделяются на симметричные и несимметричные (асимметричные). В симметричных системах шифрование сообщения и его последующее дешифрование выполняются с использованием единого, секретного ключа, копии которого есть как у отправителя, так и у получателя сообщения. Симметричные системы используются обычно для шифрования и выработки криптографических контрольных сумм.
При использовании симметричного шифрования оба пользователя вынуждены безоговорочно доверять друг другу, поскольку имеют единый, секретный ключ и, соответственно, одинаковые возможности выполнения действий, связанных с обменом данных. При этом существует вероятность несанкционированного изменения принятого сообщения самим получателем от имени отправителя.
Управление ключами связано со следующими процедурами: генерацией, распределением и уничтожением ключей, а также регистрацией пользователей. Наиболее известным решением распределения ключей является организация секретного канала передачи ключей удаленным пользователям с помощью курьерской службы, что обуславливает невысокую скорость доставки, значительную стоимость обслуживания, особенно проявляющиеся при большом числе пользователей (при этом полностью безопасность доставки не гарантируется). Более безопасным является вариант разбивки ключа на несколько частей и их доставка различными каналами. На практике широко используется вариант, при котором количество ключей резко уменьшается благодаря использованию центра распределения ключей, с которым каждый из пользователей устанавливает связь. Примером подобного решения с центром распределения ключей является организация электронного документооборота территориальных ГУ ЦБ РФ с коммерческими банками.
В отличие от симметричных криптосистем, использующих единый ключ, как для шифрования сообщения, так и для его расшифровки; в несимметричных криптосистемах для этого используется пара различных ключей, один из которых открытый, а другой секретный (закрытый). Реализующие подобную схему системы получили название криптосистем с открытым ключом (PKI – public key infrastructure). Для них характерны открытость алгоритма шифрования, отсутствие необходимости предварительного обмена ключами по секретному каналу.
При использовании криптосистем с открытым ключом субъекты для защиты своей информации самостоятельно генерируют с помощью датчиков случайных чисел индивидуальные секретные ключи. Затем на основе известных процедур и секретного ключа генерируется открытый ключ, который является общедоступным для всех, с кем требуется обмениваться конфиденциальной информацией. Следует отметить, что процедура генерации открытого ключа исключает возможность последующего получения из него секретного ключа. Таким образом, каждый из участников обмена имеет два собственных ключа: секретный и открытый. Открытыми ключами участники оперативно обмениваются между собой по незакрытым каналам связи. Полученный от партнера открытый ключ используется при реализации процедуры шифрования адресуемого ему сообщения. Процедура расшифровки полученного партнером сообщения осуществляется на основе его секретного ключа. При подобной схеме защиты многие партнеры имеют возможность сформировать и отправить шифрованные сообщения одному и тому же абоненту, и только этот абонент имеет возможность расшифровать их. При значительном числе участников обмена конфиденциальной информацией открытые ключи собираются в единый каталог и рассылаются всем участникам.
Помимо собственно шифрования сообщений криптосистемы с открытым ключом позволяют наиболее просто реализовать защиту передаваемых сообщений с помощью электронной цифровой подписи. Идея использования ЭЦП явилась ответом на растущую потребность замены подписей и печатей в документах на бумаге (платежные документы, договоры и др.) их электронным аналогам при использовании сетевых компьютерных систем с сохранением за этими аналогами юридической силы, присущей первичным документам. В отличие от идентификации автора документа посредством анализа подписи и удостоверяющей печати при использовании ЭЦП предполагается наличие у документа в электронной форме некоторого кодового дополнения, которое формируется (на основе специального программного или аппаратного обеспечения) перед отправкой с помощью секретного (закрытого) ключа у передающей документ стороны. Само дополнение представляет собой несколько строк (независимо от объема документа) символов, набор которых и их чередование однозначно связаны с содержанием конкретного документа и закрытым ключом, используемым при формировании подписи. При повторном формировании кодового дополнения к документу в случае изменения в этом документе хотя бы одного знака вид кодового дополнения изменяется практически полностью. На принимающей стороне осуществляется похожая процедура обработки полученного сообщения с использованием открытого ключа подписи. При выявлении в процессе автоматизированной процедуры обработки несоответствия между дополнением и документом принятое сообщение не принимается к дальнейшему использованию, а информация о возникшей ситуации немедленно доводится до администратора безопасности. Открытый ключ подписи передается всем получателям сообщений с ЭЦП.
Использование ЭЦП в отличие от шифрования не предназначено для обеспечения конфиденциальности обмена информацией; оно обеспечивает определение подлинности (аутентификации) сообщения и юридическую ответственность лица, подписавшего сообщение (аутентификацию источника данных). На практике две стороны, использующие ЭЦП при обмене информацией по электронным каналам связи, заключают договор, определяющий, в частности, технические особенности используемых средств, механизм разрешения возможных спорных ситуаций, связанных с применением ЭЦП.
В рамках систем электронных платежей одновременно используются как ЭЦП, так и непосредственное шифрование при передаче платежных документов. Их реализация может быть осуществлена как аппаратными, так и программными средствами.
Известными стандартами в области криптографии являются: для шифрования данных – DES (США) и ГОСТ 28147-89, для работы с электронной цифровой подписью – RSA (США) и ГОСТ 334.10 – 94. В течение трех десятков лет стандарт DES считался в международной практике одним из лучших образцов криптоалгоритмов (в его основе используются комбинации перестановок, замен и операций сложения по модулю два), используемых при хранении и передаче данных в вычислительных системах, в электронных системах платежей, при обмене коммерческой информацией и т.п. В последнее время стандарт DES (находит применение усиленный вариант стандарта – TripleDES – трижды шифрует информацию с помощью стандарта DES) теряет свои позиции из-за увеличения потенциальной возможности его взлома методом прямого подбора высокопроизводительными компьютерами (длина ключа у стандарта DES-64 символа, аналогичный российский стандарт значительно более стойкий – имеет ключ длиной 256 символов). Ему на смену приходит стандарт шифрования AES, поддерживающий длину ключа до 256 символов. Сертификацией средств защиты информации занимаются ФАПСИ и Гостехкомиссия (зарубежные средства защиты информации ими не сертифицируются). На международном уровне используется стандарт ISO 15408, описывающий набор общих критериев защищенности информационной системы, из которых набираются технические условия для каждого класса средств защиты.
В системе Банка России предписано использовать криптографические средства, реализующие отечественные стандарты безопасности: ГОСТ 28147-89 на алгоритм шифрования и ГОСТ 334.11-94 на цифровую подпись. Другим обязательным требованием по использованию криптографических средств является их сертифицированность в государственной организации, что гарантирует стойкость применяемой криптосистемы и определяет условия ее безопасной эксплуатации. Преимущественно используются аппаратно реализованные устройства криптографической защиты информации серии «Криптон» фирмы «Анкада», реализующие отечественный стандарт шифрования ГОСТ 28147-89 и имеющие сертификаты ФАПСИ. По сравнению с чисто программными реализациями применение платы «Криптон» исключает возможность появления ключей шифрования в открытом виде в оперативной памяти компьютера. Устройства «Криптон» позволяют: шифровать файлы, группы файлов и разделы на винчестерах и носителях информации; защищать информацию, передаваемую по открытым каналам связи и вычислительным сетям; разграничивать и контролировать доступ к компьютеру; формировать цифровую подпись документов. Ключи шифрования могут находиться на дискетах, смарт-картах, устройствах Touch Memory, USB-брелках. Скорость шифрования достигает скорости передачи данных в сети Fast Ethernet (до 10 Мбит/с).
Преимуществом аппаратной реализации криптографических функций защиты информации являются:
• усиление защищенности самих криптографических средств (криптографические функции гарантированно защищены от несанкционированного доступа к ним, что препятствует возможности манипуляции ключами со стороны злоумышленника);
• повышение производительности системы за счет выполнения трудоемких криптографических операций на специализированном оборудовании.
Среди программных продуктов, используемых для поддержки шифрования документов и электронной подписи, широко используются программы «Вебра-W» и «Вебра-OW», имеющие сертификат ФАПСИ.
Следует отметить, что современные многофункциональные программные средства, такие как СУБД, ОС и др., имеют встроенные процедуры криптографической защиты информации. Существуют специализированные доступные программы, например, Best Sentry 2020, Cryptext и др., позволяющие шифровать (расшифровать) данные на основе ряда алгоритмов (стандартов) на винчестерах и различных типах носителей информации.(2, с. 343 - 346)

Заключение
Криптография – наука о методах обеспечения секретности и/или подлинности (аутентичности) данных при их передаче по линиям связи или хранении. Исследования в области криптографии развиваются по двум направлениям: шифрование данных и создание алгоритмов электронной цифровой подписи. Шифрование имеет целью скрыть содержание (обеспечить конфиденциальность) хранимой или передаваемой по сетям информации, электронная подпись имеет целью гарантировать достоверность и целостность передаваемых по глобальным сетям сообщений.
Для шифрования используется некоторый алгоритм или устройство, реализующее заданный алгоритм, которые могут быть известны широкому кругу лиц. Само же управление процессом шифрования осуществляется с помощью периодически меняющегося кода ключа, обеспечивающего каждый раз оригинальное представление информации при использовании одного и того же алгоритма или устройства. Знание ключа позволяет относительно быстро, просто и надежно расшифровать текст. Однако без знания ключа эта процедура может оказаться практически невыполнимой даже при использовании компьютера.
Налаженное промышленное производство аппаратуры для криптографического шифрования позволяет резко повысить безопасность коммерческой информации при ее хранении и электронном обмене в компьютерных системах.

Практическая часть
Общая характеристика задачи
1) Построить таблицу по приведенным данным:
номенклатурный номер наименование продукции количество, шт. цена, тыс. руб. сумма, тыс. руб. % скидки сумма скидки, тыс. руб. стоимость с учетом скидки, тыс. руб.
2 Монитор 5 12,00
1 Клавиатура 25 0,25
3 Дискета 100 0,02
5 Принтер 2 10,00
4 Сканер 1 8,00


2) Рассчитать сумму скидки по каждому наименованию продукции, исходя из того, что процент скидки назначается в зависимости от последней цифры номенклатурного номера: 1 – 5%, 2 – 7%, 3 – 10%, 4 – 15%, 5 – 20%. Для расчета использовать функцию ПРОСМОТР(или ЕСЛИ), а для определения последней цифры номенклатурного номера – функцию ОСТАТ. Результаты вычислений округлить до двух знаков после запятой, используя функцию ОКРУГЛ.
3) Сформировать и заполнить ведомость расчета стоимости продукции с расчетом скидки.
4) По данным таблицы построить гистограмму.

Рассчитаем процент скидки в зависимости от последней цифры номенклатурного номера: 1 – 5%, 2 – 7%, 3 – 10%, 4 – 15%, 5 – 20%.

Таблица 1.
номенклатурный номер % скидки
102 2 0,07
101 1 0,05
403 3 0,1
205 5 0,2
304 4 0,15

Для определения последней цифры номенклатурного номера используется функция ОСТАТ.


Формулы расчета таблицы 1

Номенклатурный номер % скидки
102 =ОСТАТ(A5;100) 7
101 =ОСТАТ(A6;100) 5
403 =ОСТАТ(A7;100) 10
205 =ОСТАТ(A8;100) 20
304 =ОСТАТ(A9;100) 15

Расчет стоимости продукции с учетом скидки. Таблица 2.
номенклатурный номер наименование продукции количество, шт. цена, тыс. руб. сумма, тыс. руб. % скидки сумма скидки, тыс. руб. стоимость с учетом скидки, тыс. руб.
2 Монитор 5 12,00 60,00 0,07 4,20 55,80
1 Клавиатура 25 0,25 6,25 0,05 0,31 5,94
3 Дискета 100 0,02 2,00 0,1 0,20 1,80
5 Принтер 2 10,00 20,00 0,2 4,00 16,00
4 Сканер 1 8,00 8,00 0,15 1,20 6,80

Расчет произведен с помощью функции ПРОСМОТР.


Формулы расчета стоимости продукции с учетом скидки

номенклатурный номер наименование продукции количество, шт. цена, тыс. руб. сумма, тыс. руб. % скидки сумма скидки, тыс. руб. стоимость с учетом скидки, тыс. руб.
2 Монитор 5 12 =C5*D5 0,07 =ПРОСМОТР(A5;Лист2!B5:B9;Лист3!E5:E9)*F5 =E5-G5
1 Клавиатура 25 0,25 =C6*D6 0,05 =ПРОСМОТР(A6;Лист2!B6:B10;Лист3!E6:E10)*F6 =E6-G6
3 Дискета 100 0,02 =C7*D7 0,1 =ПРОСМОТР(A7;Лист2!B7:B11;Лист3!E7:E11)*F7 =E7-G7
5 Принтер 2 10 =C8*D8 0,2 =ПРОСМОТР(A8;Лист2!B8:B12;Лист3!E8:E12)*F8 =E8-G8
4 Сканер 1 8 =C9*D9 0,15 =ПРОСМОТР(A9;Лист2!B9:B13;Лист3!E9:E13)*F9 =E9-G9


Отчетный период
с по
__.__20__ __.__20__


Ведомость расчета стоимости продукции с учетом скидки

номенклатурный номер наименование продукции количество, шт. цена, тыс. руб. сумма, тыс. руб. % скидки сумма скидки, тыс. руб. стоимость с учетом скидки, тыс. руб.
2 Монитор 5 12,00 60,00 0,07 4,20 55,80
1 Клавиатура 25 0,25 6,25 0,05 0,31 5,94
3 Дискета 100 0,02 2,00 0,10 0,20 1,80
5 Принтер 2 10,00 20,00 0,20 4,00 16,00
4 Сканер 1 8,00 8,00 0,15 1,20 6,80
Итого 133,00 30,27 96,25 0,57 9,91 86,34


Бухгалтер_______________________________

Таблица 3
161
Результаты вычислений округлены до двух знаков после запятой, с использованием функции ОКРУГЛ.

Отчетный период
с по
__.__20__ __.__20__


Формулы расчета стоимости продукции с учетом скидки

номенклатурный номер наименование продукции количество, шт. цена, тыс. руб. сумма, тыс. руб. % скидки сумма скидки, тыс. руб. стоимость с учетом скидки, тыс. руб.
2 Монитор 5 12 =ОКРУГЛ(C10*D10;2) 0,07 =ПРОСМОТР(A10;Лист2!B5:B9;Лист3!E5:E9)*F10 =ОКРУГЛ(E10-G10;2)
1 Клавиатура 25 0,25 =ОКРУГЛ(C11*D11;2) 0,05 =ПРОСМОТР(A11;Лист2!B6:B10;Лист3!E6:E10)*F11 =ОКРУГЛ(E11-G11;2)
3 Дискета 100 0,02 =ОКРУГЛ(C12*D12;2) 0,1 =ПРОСМОТР(A12;Лист2!B7:B11;Лист3!E7:E11)*F12 =ОКРУГЛ(E12-G12;2)
5 Принтер 2 10 =ОКРУГЛ(C13*D13;2) 0,2 =ПРОСМОТР(A13;Лист2!B8:B12;Лист3!E8:E12)*F13 =ОКРУГЛ(E13-G13;2)
4 Сканер 1 8 =ОКРУГЛ(C14*D14;2) 0,15 =ПРОСМОТР(A14;Лист2!B9:B13;Лист3!E9:E13)*F14 =ОКРУГЛ(E14-G14;2)
Итого =СУММ(C10:C14) =СУММ(D10:D14) =СУММ(E10:E14) =СУММ(F10:F14) =СУММ(G10:G14) =СУММ(H10:H14)


Бухгалтер_______________________________




Тэги: криптографические методы защиты информации и их использование при работе в сети, средства анализа защищенности компьютерных сетей, криптография, шифр, ключ,



x

Уважаемый посетитель сайта!

Огромная просьба - все работы, опубликованные на сайте, использовать только в личных целях. Размещать материалы с этого сайта на других сайтах запрещено. База данных коллекции рефератов защищена международным законодательством об авторском праве и смежных правах. Эта и другие работы, размещенные на сайте allinfobest.biz доступны для скачивания абсолютно бесплатно. Также будем благодарны за пополнение коллекции вашими работами.

В целях борьбы с ботами каждая работа заархивирована в rar архив. Пароль к архиву указан ниже. Благодарим за понимание.

Пароль к архиву: 4Q3519

Я согласен с условиями использования сайта